Docker container run return error: "exec format error"


I have the Armbian OS (on ARM controller-board) and I ran on it the Docker…
Then I installed a container with InfluxDb and run it.
Then I dowloaded a container with Grafana and try to ran it.
But I got the error:
standard_init_linux.go:190: exec user process caused “exec format error”
Can anyone help me with this error?


Docker may have a problem to detect right arm version

Maybe… But I run InfluxDb container on my ARM controller without any error.

Sure. InfluxDB image is built from different base image, which may have different multiarch support.
Only you have a admin access to the system, so you only can prove any theory. There can be many Docker related issues: user namespaces, storage drivers, permissions, … and without proper details (how did you start container, which image, docker daemon configuration, used fs permissions, …) is any advice just blind guess.

Your problem:

 $ docker run --rm mplatform/mquery grafana/grafana
    Image: grafana/grafana
     * Manifest List: No
     * Supports: amd64/linux

 $ docker run --rm mplatform/mquery influxdb
    Image: influxdb
     * Manifest List: Yes
     * Supported platforms:
       - linux/amd64
       - linux/arm/v7
       - linux/arm64/v8

Grafana doesn’t provide multiarch Docker image, so you are trying to run amd64 code on your arm device.

On github, the task of porting Grafana to ARM7 is not yet closed…
I will wait…