Error when i run "grunt"


I was following this guide to install grafana on my local.

I face the below error when i run the command “grunt”,

reEmptyStringTrailing = /(__e(.*?)
SyntaxError: Invalid regular expression: missing /
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions…js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Object. (/srv/data/sources/src/
at Module._compile (module.js:460:26)
at Object.Module._extensions…js (module.js:478:10)

Any idea?

node version: v0.12.0
nodejs version: v0.10.25
npm version: 2.5.1
go version go1.5 linux/amd64
machine: Linux

Thanks in advance for your help

You need Node LTS (v6.9 currently) and Go 1.8

Hello @torkel,

Thanks for the quick reply.

So i have to run

nvm install v6.9.0

Plese help me as am new for grafana and nodejs projects.
Can you please update this page accordingly so that it will be easier for me to follow the steps mentioned here. :slight_smile:

Best regards