Grafana gives "Problem! unexpected error" but only when using dyndns

So I’ve installed grafana on my synology NAS using docker and the official container. I use a non standard random port (32770) outside the docker, which translates inside docker to the standard 3000. Then I am able to login and use grafana just fine with the IP address of the NAS inside my LAN. So something like:

But then if I port forward 32770 on my router from outside my LAN to 32770 inside my LAN, and I am using dyndns to have a domain name for my home network, I get this error when I try to go to grafana:


I checked the logs but nothing at all seems to show up for this failure. Any ideas?

I tried changing the grafana.ini “domain” parameter per these instructions: Run Grafana behind a reverse proxy | Grafana Labs

I also tried changing “root_url”, but either I’m doing it wrong or that’s not my problem. Any ideas?

There must be an error somewhere :slight_smile:

Are you able to access the chrome dev tools and see if there is an error in the console or on the network tab there? When exactly are you getting the error? Is it the data source that is not working or is it Grafana failing to load its javascript files?

Ok, I was able to get an error. Also, very strangely today, it’s also sometimes able to load. Since it’s intermittently failling now (when I use the domain instead of direct ip address) I don’t know if something I changed in the ini file helped? Seems like it would have either fixed or not fixed it, but…

Here is the failure from f12 in chrome:

grafana f12 error

Is this perhaps a proxy issue?

Yes. Seems to be a proxy issue. Looks like the redirect is failing the CORS validation and the browser is basically blocking the request.