Grafana migration from centos to Ubuntu

Dear All ,

I want to migrate Grafana from Centos VM to Ubuntu VM.

what is procedure grafana migration?

version: 7.5.9 os : linux cent os


What hypervisor or virtualization are you using?

using Centos VM ,

Grafana need to be migrate to Ubuntu

Sure but what kind of virtualozatiom technology are you using.

Anyways try this . Are you using the default sqllite grafana install?

  1. Install same version on Ubuntu. Stop the grafana service in Ubuntu
  2. Copy and overwrite defautls.ini and grafana.db files from centos grafana over to the new grafana in Ubuntu
  3. Start grafana service in Ubuntu

See what happens.

thanks above steps are working

  1. installed new version
  2. copy old grafana.ini and grafna.db file from centos to ubnutu os
  3. start grafana
  4. all dasbhoard are visiable
1 Like

I tried the same procedure as @ prashantnitt07.

  1. installed grafana 8 at the new Ubuntu server
  2. copied grafana.db and grafana.ini from centOS to Ubuntu
  3. restarted grafana, but that failed:
root@influx-grafana:/var/lib/grafana# systemctl status grafana-server
× grafana-server.service - Grafana instance
     Loaded: loaded (/lib/systemd/system/grafana-server.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Mon 2023-01-02 18:03:36 CET; 6s ago
    Process: 36598 ExecStart=/usr/sbin/grafana-server --config=${CONF_FILE} --pidfile=${PID_FILE_DIR}/ --packaging=deb cfg:>
   Main PID: 36598 (code=exited, status=1/FAILURE)
        CPU: 218ms

Jan 02 18:03:36 influx-grafana systemd[1]: grafana-server.service: Scheduled restart job, restart counter is at 5.
Jan 02 18:03:36 influx-grafana systemd[1]: Stopped Grafana instance.
Jan 02 18:03:36 influx-grafana systemd[1]: grafana-server.service: Start request repeated too quickly.
Jan 02 18:03:36 influx-grafana systemd[1]: grafana-server.service: Failed with result 'exit-code'.
Jan 02 18:03:36 influx-grafana systemd[1]: Failed to start Grafana instance.

Any idea?

1 Like

Check for grafana.ini

Share grafana log detail

what version was the previous one?
did you copy those files to their respective folders?

Issue is solved.
I copied grafana.ini and grafana.db again.
Now it works, no idea what was wrong…

1 Like

I think copy both file was not properly.