Is there a way to config maximum returned traces

There is a Limit on Tempo TraceQL page,
image
According this doc: Configure | Grafana Tempo documentation.
I set
queryFrontend.config.search.max_result_limit: 100, but I still is able to set the limit to 300 and even a extremely big number.

I also searched Mimir repo, and didn’t find this max_result_limit.

Hi! If the limit in the UI is greater than query_frontend.search.max_result_limit, the actual limit is query_frontend.search.max_result_limit. Here you can check the code that adjusts the limit based on the received param in the query and the actual config.

Hi @mariorodriguez, thanks for your reply. But when I see the return results. it would return more than 100 results. I think my configuration might be wrong. I am using helm to deploy Mimir, if I have customized changes, I would use yq to replace the default value.
Something like this:

queryFrontend:
  config:
    search:
      # The maximum allowed value of the limit parameter on search requests. 
      max_result_limit: 100

But I found the original config.search doesn’t have a max_result_limit.

It seems even though I set the limit is 10 on the front page, I would get more than 10 results.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.