MySQL-found row with with no time value

I can any one help me why I am getting this error in Grafana.

ERROR- Found row with no time value.

  • Which version of Grafana are you using? Are you using the alpha version of the MySQL plugin?
  • If you look at the data returned by the query (either by creating a table panel or executing the query in MySQL Workbench) do you have any nulls in the datetime column?
  • What data type is your date field? There is only limited support in the alpha version. The full version of the plugin supports a lot more types.

We are releasing Grafana 4.5 today/tomorrow which will include the full version of the MySQL plugin. It is also available in the current nightly build:

I have the same error: “Found row with no time value” with a time series format.
I am hosting on for my tests.
If I take the query from the Generated SQL query, and run in from the shell, the query runs fine.

What does your query look like? And what does the table schema look like? There are two reasons this error can occur:

  1. In your result you are returning a null value for the time_sec field.
  2. You have a type in your table that the MySql data source plugin does not know how to convert to either a datetime or value.
1 Like

Thank you for the help, my issue was due to my time_sec field formatting.

select UNIX_TIMESTAMP(bb.timestamp), bb.timestamp from bb limit 1;
| UNIX_TIMESTAMP(bb.timestamp) | timestamp |
| 1508494191.882357 | 2017-10-20 10:09:51.882357 |
With the seconds (1508494191) it worked as expected.