Template Init Failed - Connection Error


Every first time i try to opem my dashboard URL at grafana cloud, the browser display an error “Template Init Failed - Connection Error” (image attached). Then I have to click at the upper right icon with a red cross (image attached), and accept to run a non secure script. After that everything runs perfectly.

I would like to open the page without having to click on the red cross. Is that possível?

I also tried on internet explorer and happens the same.

Then i tried to open in an ipad, with safari. In this case the page could not be loaded because there was no red cross icon do click on. I think it should be able to open on Ipad.


What data source is this for? Is this a https problem with your data source?

The datasource is Zabbix.
I forgot to mention that this problem doesn’t happens with a on premise grafana (same datasource). Only with grafana cloud.

Is it this problem: Switch grafana from http to https, all grpahs are gone

I changed the datasource connection from direct to proxy and it worked. I can also open the page from Ipad.
Thanks a lot.

I open the console from the chrome and copy the error message. see it below.

Yes, it is a mixed content warning (mixing insecure http with https) so my link above should help you. Or is everything working now after changing to proxy?

Everything is working fine, Thanks a lot.

1 Like