Updating Docker/Ubuntu causing dashboard to fail (could be InfluxDB) would love some advise


I’m not sure what is causing this but I thought it was InfluxDB updating itself to the latest version (image: “influxdb:latest”) as it runs as a docker corrupting things.

I have a telegraf.conf file that is using SNMP to import data into InfluxDB and it’s been fine for about a year now with regular Ubuntu updates.

Today I ran apt-get update and 1 very important dashboard stops working and no data is fed into InfluxDB if I check inside the database.

Luckily I have a snapshot I can revert to test.I’m not sure which one of these updates is causing it, but I’d guess it is the first line which is Docker:

sudo apt-get update
Hit:1 https://download.docker.com/linux/ubuntu focal InRelease
Hit:2 https://repos.influxdata.com/ubuntu focal InRelease
Hit:3 http://gb.archive.ubuntu.com/ubuntu focal InRelease
Hit:4 http://gb.archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:5 http://gb.archive.ubuntu.com/ubuntu focal-backports InRelease
Hit:6 http://gb.archive.ubuntu.com/ubuntu focal-security InRelease Reading package lists... Done

This is my docker compose file, pretty standard:

This is my telegraf config file that pulls information from 100s of devices, this one is pointing to just 1 devices for testing.

This is what it should look like, after the upgrade it says no data.

What could it be and what do you think I could try next?


Hi @g0nz0uk ,

Are you still encountering this issue? Have you recently changed that Docker Compose? I see that you are pulling Grafana 7.5.4, so I’m guessing you’ve edited the file recently. Have you tried pulling an earlier version of Grafana? What version were you running before? Any errors in the logs? Any red errors in the corner of panels when you try to load them?

This topic was automatically closed after 365 days. New replies are no longer allowed.