Alert List strange behavior

Version 4.6.1 running on Debian 9

With Current state I see 4 green hearts.
When I change to Recent state change I don’t see anything, but when I change Max items to 1 I see one green heart when i change to 10, I see nothing. If I change to 2 I see one green heart and one red after this I can change to almost any value but I will never see more than one green and one red.

I tried same Debian but with 4.6.0 beta 2 then it works correct.

That is very strange, I am unable to replicate it here:

Can you?

No, I cannot replicate it from the link.
I saw that you have 4.7.0, I will update my installation and try again.
About my installation: I installed 4.6.0, then 4.6.0 beta2 and then 4.6.1(with dpkg -i)

I had a clone from my instance(guest,running VirtualBox) which had “4.6.0 beta2” I upgraded it to 4.6.1 with dpkg and Alert List is working correct, like the link above.
On my active instance I have 4.6.1, I installed 4.6.1, again, over 4.6.1 but it have the same problem with Alert list. It is something with the installation on the active instance.
I will try other stuff and get back.

Thank you for your help so far.

I tried to uninstall Grafana but after I installed it again all my dashboards was still there and Alert List is still wrong. I deleted grafana.ini manually but still after this all my dashboards are still there and Alert List is not working
How can I do to really delete everything?
i tried:
apt-get remove grafana
apt-get remove --auto-remove grafana
apt-get purge grafana
apt-get purge --auto-remove grafana
all commands with su

After I took a new Debian and installed 4.6.1 alert list is ok.

What I noticed now in your link and my Alert List is that Max items doesn’t when you selected “Current state”