Data points outside time range

I used simple jason plugin to bring in some timeseries data into Grafana.
I get the following response from server for Grafana request range of 2017-06-26 00:00:00 to 2017-06-26 23:59:59 :

“target”: “Ret Fan VSD”,
“datapoints”: [
1498435201 (equivalent to :Monday, 26-Jun-17 00:00:01 UTC)

1498520701 (Equivalent to: Monday, 26-Jun-17 23:45:01 UTC)

However, there is no data shown and I have “Data points outside time range” error.
This is indicated to be due to timezone mismatch or missing time query in filter.

I would like to know what I am missing as the response is within that time and unix utc format as checked in:

Have you tried milliseconds since epoch? For me (writing with the DataFrameClient - python) it did the trick. I got the same error message as long as I was using seconds since epoch. By adding the additional zeros everything turned the way I expected.
I think only these Formats are supported:

  • epoch in milliseconds
  • now
1 Like

@gaia worked nicely, heaps thanks for your help

I have similar issue with postgresql where the data is converted to epoch milliseconds causing the alerts to fail.
1531954800000 instead of 1531954800

Hi. I have got similar problem. script a below:
extract(epoch from “date”) as time,
“action_description” as metric,
count(“subscriber”) as Subscriptions
FROM public.“VBI_KZ”
and status = ‘FULFILLED’
group by “date”, “action_description”
order by “date”

How did you solve it?