Get rid of the grafana PPA

Hello dear community,

Got a quick question. I used to use a native installed grafana. But I switched to a docker-run grafana. That works really well now.
The problem I experience now is that during the native intallation I installed PPA’s.
The PPA’s are still in de list but not valid anymore.
So everytime I run ‘sudo apt-get update’ I get the following error:

W: GPG error: packages grafana stable InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 9E439B102CF3C0C6
E: The repository ‘packages grafana stable InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

The question is: how do I remove the PPA from the list? So in other words, how do I get rid of the error above.

I already tried:

  • sudo ppa-purge deb-src deb packages grafana stable main
  • sudo ppa-purge deb-src packages grafana stable main
  • sudo ppa-purge packages grafana
  • sudo add-apt-repository --remove ppa:packages grafana
  • sudo add-apt-repository --remove ppa:
  • sudo apt-get clean

Without any luck.
Could anyone send me in the right direction?

ps] had to make some adjustments in the text to avoid links.

welcome to the :grafana: community @pepper662

here’s a post we created to address recent GPG related errors

Hope the commands you will find will help you to overcome the error

Hello Antonio,

Thanks. I read the posts. It describes me how to renew the key. But as I am already running everything in a docker I really do not need the key in the first place. Hence the question if I can remove the link. And how to do it.