Grafana 3.2 Does Not Display Data

I am running grafana 3.2 on CentOS7 (the output of rpm -qa | grep -i grafana is grafana-4.3.2-1.x86_64), and whenever I export a dashboard as a json, I am not able to properly reimport the dashboard, or share it on, because the “__inputs” field soecified at the bottom of this page: “” is not present. Is there a simple fix to this problem?

Update: Even when manually changing every "datasource": null field in the exported json to "datasource": prometheus server I find that upon import, I still end up with a dashboard that displays no data. (Widgets/Graphs, as before, are arranged and defined correctly, but there is no data displayed by said widgets. The value of template variables is also null).

Did you export the dashboard via Share > Export ?

That export should templatize all data sources and add a section for data source types.

No, I had not. I had simply copied the text of the “view json” page from the “manage dashboard” menu. I tried exporting the dashboard as you recommended, and that fixed my problems. Thank you.

EDIT: I now remember, I had also been using the “view json” button under the Share > Export page, and I ran into similar problems.

Actually, I ran into the same problem after I stopped the grafana server, killed and restarted the prometheus server, deleted the grafana.db file under /var/lib/grafana, and started the grafana server. Then, even when importing the json file I downloaded via Share > Export, I got the following page:

Edit: I also published the code for this dashboard on, if anyone would like to take a look.

Note: When I create a new dashboard, and then manually “copy” (create new graphs with the same settings and queries) the graphs of the original dashboard to the new dashboard, I see the proper data.
However, importing the old dashboard, whether by providing a link to, pasting the json, or uploading the appropriate .json file, results in a blank screen as above.

Update: The bug only seems to appear when I am running the grafana server and the prometheus server on the same instance/machine. When I configure the prometheus data source to point to http://localhost:9090, I get an error as described above. However, when I configure the data source to point to a server that is not localhost, even upon stopping the grafana-server, deleting the grafana.db file, and restarting the grafana server, the bug above does not appear.