Grafana-cli command not found

Hello, could somebody help, how to enable grafana-cli?
I would like to install zabbix plugin but my terminal says - ** grafana-cli command not found.**

My grafana version - 4.2.0

How did you install Grafana and on what OS are you running on? The cli tool is located in Grafana’s bin directory and it should be added to your path automatically unless you are building from source.

1 Like

Thanks for your reply. I already solved this problem. Only after installed from Source grafana has worked.
From packages grafana installed incorrectly without CLI and other modules.

OS - Ubuntu

How did you get it to work? I’m trying to get my grafana-cli to work. whenever i try to do a grafana-cli command it says command not found. The docs dont mention anything about how to install the grafana-cli. When i try running it, a new command prompt just opens and closes really fast, nothing actually happens.

How did you install Grafana? Did you follow the installation instructions? If you ran sudo apt-get install grafana then you got an old version of Grafana that is not (and never has been) maintained by us. This is the wrong version:

grafana (2.6.0+dfsg-1 Ubuntu:16.04/xenial [amd64]

Check the version by looking at the footer of any page that is not a dashboard (the Preferences page or Server Stats for example):


Well for me I did the follow at Ubuntu 16.04 to enable in PATH:
-access the bashrc file at ~/.bashrc by the vim or other editor you like.
-At the end of file and modify to look like at Grafana version 4.6.2:
export PATH="$PATH:$HOME/grafana-4.6.2/bin"
-close the terminal and when open again you should be able to perform the grafana-cli command from anywhere because grafana-cli is resident at your grafana installation directory and locate at sub directory also named bin.

I am facing same issue while installing on Redhat - Linux " bash: grafana-cli: command not found", please let me know or provide me if you have any documents or steps .