Marcusolsson-csv-datasource- local path does not allow read from local machine

Hi, I have installed marcusolsson-csv-datasource plugin but unfortunately I’m not able to reach my csv using the local path. I have tried using testdata option and copied my data inside grafana/public/testdata path but the same case it does not recognize my file.

I’ll appreciate if you could help me on this matter.

Kind regards,

To read CSV on the local machine, you need to allow local mode. Let me know if the problem persists after you’ve enabled this.

How about the issue of grafana telling me that the number of fields are incorrect

If one uses the CSV datasource to read a CSV file on a local drive (e.g. a NAS drive), would the URL path be something like this?


or this?


I don’t know enough about Windows to say for sure, though due to this issue, you’d need to use forward-slashes on Windows:

This should work:

1 Like

Thanks @marcusolsson I am running Grafana on a Debian Linux machine (not Windows). Given that, do I still use forward-slashes? I have tried many variations of the file path with no success. I though for sure that


would work.

For any Linux (or macOS) machine, you should use forward-slashes. Running pwd in the directory should give you the correct path.

1 Like

Thanks Marcus. For Grafana running on a Debian Linux machine accessing a .csv file on a local NAS (Synology), I mounted the drive and here is what worked:

1 Like

cool… It works!!! Thanks @marcusolsson

Hi Marcus Olsson, I’m in desperate need of your helping, I wrote local path but Grafana gives me this error: stat /home/kali/Data/data.csv: permission denied. what should ı do?

1 Like

Link to doc is outdated. Correct link Configuration | CSV for Grafana

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.