Problem: invisible graph


We’ve been using Grafana for a while with Graphite data.

Recently, we installed version 4.3.1-1 of Grafana and built our first dashboards using elastic search with collected data.

Our problem is the following: If we use a “Quick range” lower than a day, the graph disappears.

For example, the “Last 24 hours” or “this week” time ranges work well but anything lower like “last 6 hours” the graph becomes invisible.

If we slowly mouse over the invisible graph, all the data is there but it’s just not visible.

We also tried the same operations using the Graphite data but cannot reproduce the problem.
Can you please help us in resolving it.

Sorry, I’m talking about ElasticSearch with collectd data.

What value have you set for the Group by time interval? Do you have a lot of nulls in the data?


Hi Daniellee, I feel cheap not having seen that post from Torkel since it seems to be our problem.
Changing the “null value” option makes the graph appear but incomplete.

Following is the JSON generated. As we can see, the min_doc_count is set to zero.
Could you tell me how/where do we update this field if needed.

“alias”: “wait”,
“bucketAggs”: [
“field”: “@timestamp”,
“id”: “2”,
“settings”: {
“interval”: “auto”,
“min_doc_count”: 0,
“trimEdges”: 0
“type”: “date_histogram”
“dsType”: “elasticsearch”,
“hide”: false,
“metrics”: [
“field”: “value”,
“id”: “1”,
“meta”: {},
“settings”: {
“missing”: 0
“type”: “avg”
“query”: “host:”$Serveur" AND plugin:“cpu” AND type_instance:“wait”",
“refId”: “C”,
“timeField”: “@timestamp

Thanks again


Min Doc Count is found under the Group By options:

I changed the “Min Doc Count” to 1 and got the graph but it also resolved it forcing the Interval to 1 min instead of “auto”.

Thanks again

1 Like