Unable to create datasource on Hosted grafana

When I’m trying to configure a datasource on hosted grafana I’m not able to set aws credentials like I used to do in the self-hosted one. There I just set the environment variables to override aws credentials and then I assume the role. But on hosted grafana I don’t have access to the environment variables. Any idea how I can assume a role?

Besides that I also tried without assume role with a different account but that also did not work. (tried “aws cloudwatch list-metrics” with those credentials and it worked) Any ideas?

You cannot use a credentials file on Hosted Grafana as you say. You should be able to do it with an Access and Secret instead. Sounds like you might not have configured it correctly?

Here is our Cloudwatch policy. Are you missing any of these actions (especially the 3 cloudwatch actions)?

    "Version": "2012-10-17",
    "Statement": [
            "Action": [
            "Effect": "Allow",
            "Resource": "*"

You might need some extra permissions for EC2 if you are querying that data:


Yes you were right about the permissions thank you.

I created a user new and group and assigned the policy you mentioned to it and it worked.
Do you know if it’s possible to assume role in any way?