Username is not shown in header, despite setting the configuration

I want to see the following header in the request, X-Grafana-User: yaki,
but it doesn’t show up, neither in the url nor in a closer look of the request header.

In my grafana.ini I have set; send_user_header = true
But nothing happens. I am using elasticsearch with the Server option selected.
I am logging in using the standard Grafana auth, which is the default way. But still, the username doesn’t show up in the header.
I also tried setting “With credentials” in datasource, but nothing happens.
Is there something I am missing? Do I have to use another way of authentication? Other configs?