Grafana/InfluxDB - Network Error: undefined(undefined)

Hello fellow community.

I’ve installed and configured InfluxDB (1.3.5-1), Telegraf (1.3.5-1) and Grafana (4.4.3-1) on a new server.

My Telegraf agent is successfully posting data into InfluxDB which I have verified by both changing the DB they post data to, and via a select query directly on the Influx prompt.

I have configured Grafana to use InfluxDB http://localhost:8086 as the data source. Test/Save config displays a successful connection.

I’ve been tailing the InfluxDB logs when creating a new dashboard, and I can see the GET request for measurements. Using the query builder Grafana is listing the measurements that are in InfluxDB, however I end up with “Network Error: undefined(undefined)” on the graphs.

I’ve been banging my head against a wall on this issue and I’m now at a loss as to where to go from here (every other influx/grafana installation has just worked…)

Thanks in advance!

I’ve managed to work out the issue.

I ran a TCPDUMP looking for network traffic when the graphs load/refresh - to which there is none.
I verified on another working grafana instance and there is indeed much more network traffic.

My InfluxDB data source is set to PROXY, however it doesn’t appear to be proxying at all.

  • Does your Grafana server (the server that Grafana is installed on) have access to your InfluxDB?
  • If you examine the error in the Chrome Dev Tools, can you get more information? Here is a guide for looking at the raw data returned from InfluxDB.
  • If you check the Grafana server logs, do you see any errors?

Yep, both Grafana and InfluxDB are running on the same server.
I have not checked the chrome Dev tools, I’ll check it tomorrow.
No errors in the Grafana logs.

I should have updated the thread before I left the office, but I did manage to get it working correctly on another PC in the office. My attention has now been directed to my laptop, I’m thinking it might have something to do with our SOE, but I can’t imagine what…

@butters Did you ever figure this out? I’m having the same issue, except with Hosted Grafana, so my available tools to troubleshoot are limited.

Did you check this:

In your case with Hosted Grafana, can you access your InfluxDB server from outside of your company network and firewall?

See that you asked here as well: Unhelpful error with Hosted Grafana with InfluxDB data source: "Network Error: undefined(undefined)"

@jwf Yes and no. I think I have figured out most of the symptoms, and managed to implement a very poor bandaid solution that works for me, but unfortunately probably won’t work in your scenario.

I feel it’s a networking issue. I’m not too savvy on my networking especially from an application point of view, my gut tells me it’s a DNS/routing problem. A TCP dump on the grafana/influxdb server shows 0 byte responses to the queries when this error is displayed.

I’ve discovered that in my case, if I’m on the corporate WiFi I receive the above mentioned nondescript error, however if I plug that same laptop into an ethernet cable there’s no errors whatsoever and the graphs draw without a problem.

I’m running grafana in a two node Linux failover cluster with a virtual private IP. Grafana (even when configuring in grafana.ini) does not like to respond to queries on the VIP and I receive the above mentioned nondescript error. I suspect this is because the VIP is a virtual IP that is assigned to eth0 and doesn’t technically have a hard interface. Using all the DNS and proxy trickery that I know I was unable to resolve this particular error.

I’ve implemented the following bandaid solution that seems to work (for now):

  • Use default grafana.ini for any URL/IP address settings so that grafana listens on all interfaces on default port.

  • Configure apache to listen on a new port (such as 3001) and create configuration file /etc/httpd/conf.d/grafana.conf on each cluster node. Create redirect rule for the grafana specific hostname that maps to the VIP ( to the cluster node’s hostname/port ( - depending on which node is running the cluster resource).

1 Like

I am able to access it from an external network. In my case, I don’t have it running on a company network anyways right now. But I confirmed it was accessible from the outside.