Unhelpful error with Hosted Grafana with InfluxDB data source: "Network Error: undefined(undefined)"


When adding a new InfluxDB data source to Hosted Grafana, after clicking Save & Test, the UI comes up with an unhelpful error:

Network Error: undefined(undefined)


This is almost the exact same issue in this thread, except I’m using Hosted Grafana instead of hosting it myself.

I’ve verified that the database is able to be reached from the outside and that it is actually collecting data. I have a Telegraf instance writing data to InfluxDB and I checked there is data there. But I’m at a loss for how to debug this further since the error is unhelpful and I don’t have any access to try debugging it further at the Grafana level.

Any help or thoughts?

Can you open chrome dev tool console, any error there?

Using Firefox, but the developer console didn’t seem to have anything useful:

Look at the network tab and find the request that looks something like this:

http://grafana.staged-by-discourse.com/api/datasources/proxy/11/query?db=site&q=SHOW DATABASES&epoch=ms

@daniellee Sorry for the late response.

I looked now and didn’t see any requests like the one in your screenshot. However, I manually entered the API URL you linked above for my hosted instance, and I was only given one message there:

“Datasource is not configured to allow this database”

Screenshot of JSON outpit

Any ideas what this means?

This is very strange - that error message is a security check to make sure that the user is not trying to access other influxdb databases than the one specified on the config page in the Database field.

To get the error on Firefox, do the following:

  1. First open the datasource config page
  2. Open the Firefox Dev Tools and switch to the Network tab. If there are requests in the list, press clear (the little trashcan on the left)
  3. Click on the Save and Test button and you should see the following:
  4. Click on the last entry and take a screenshot of the headers tab:
  5. Then a screenshot of the response tab:

I’m still not seeing an entry for any queries. I open the data source, open Dev Tools, switch to the Network tab, and I only see this.

Starting from where you are now.

Do this:

Then this:

I also have similar problem
When I run save and test query in url I see the same error as title.
But when get the test url from console and run this in browser I get

Console says:

VM48:1 Mixed Content: The page at ‘https://kala1.grafana.net/datasources/edit/23’ was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint ‘’. This request has been blocked; the content must be served over HTTPS.

@kala1 that looks like a totally different problem - you are getting a mixed content error. Have you configured the data source to be in “direct” mode? (Direct means going directly from the browser to the database and proxy means requests are routed via the Grafana server backend before being routed to the database). Try changing to proxy.

@daniellee This is a late response, but I followed the steps you detailed above. I still don’t see a query operation in the developer tools.

@jwf even if you press the Save/Save and Test button again? I just tested adding an InfluxDB data source to a GrafanaCloud instance and it looked like this:

The query is async so it might take a few seconds to turn up if it is timing out.