Mysql data source unusable with Grafana cloud

The Mysql data source doesn’t work with grafana cloud.

I am using identical settings as what i use to test with my local grafana instance but it fails with “Failed to update datasource” No additional feedback.

Also the form is likely unnecessarily clunky for Mysql

So i am force to set “TLS/SSL Root Certificate” which i do on both sides.

Where is the mysql server located and how are you creating the datasource?

Mysql is a planetscale instance,, located in Singapore

To create the data source i went to the UI and filled the form:
Ticked With CA Cert
Entered the same TLS/SSL Root certificate as my machine.

I tried to follow Planetscale blog for common SSL erros, and used the Mozilla provided CA to no avail

Then when clicking “Save & Test” I see that error.

Is there any way to see more about what the error is like i can do when there is an error on my local Grafana instance?

EDIT: After finding that blog post, i scrolled through the whole content

Support’s notes from the field following this and pasting the let’s encrypt provided CA certificate worked! Resolved

1 Like